Plans to go open source

short notes for those not reading all the forums
User avatar
Dchaps
Sr. Member
Posts: 756
Joined: Thu Jun 20, 2013 3:53 pm
Location: Sunnyvale Trailer Park

Re: Plans to go open source

Postby Dchaps » Wed Dec 30, 2020 4:52 am

I chased my tail quite abit when it came to the login forms between using php 5.6 and 7.4, i ended up updating the login forms myself aswell and even tried downgrading

I had an issue where the apache access_log was showing an incorrect symlink for the wrong game inside startsession.php

I also had a problem with dnsmasq and systemd-resolve running concurrently, and on every system reboot /etc/resolv.conf would reset

but after a long battle she works on ubuntu server! :mrgreen:

Image
Came to kill a champ aint even nobody with you

hobbes_182
Full Member
Posts: 249
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius
Contact:

Re: Plans to go open source

Postby hobbes_182 » Mon Jan 04, 2021 2:37 pm

Has anyone tried logging into their open source server with an actual PlayStation 2?

I can log in successfully on emu, but I am having no luck on console :-[

On emu I have the DNS1 setup to 192.0.2.1 and edited my .ini file to reflect the server's IP.

I have played a few maps and emu and everything runs smoothly.

Here is my server info incase someone wants to try connecting on console:

Code: Select all

DNS 1 - 192.0.2.1 IP - 172.15.200.176

User avatar
hill73n
Full Member
Posts: 223
Joined: Mon May 20, 2019 4:49 am
Location: Australia

Re: Plans to go open source

Postby hill73n » Tue Jan 05, 2021 10:53 am

Has anyone tried logging into their open source server with an actual PlayStation 2?

I can log in successfully on emu, but I am having no luck on console :-[

On emu I have the DNS1 setup to 192.0.2.1 and edited my .ini file to reflect the server's IP.

I have played a few maps and emu and everything runs smoothly.

Here is my server info incase someone wants to try connecting on console:

Code: Select all

DNS 1 - 192.0.2.1 IP - 172.15.200.176
Hey hobbes. Nice work!

Yes. Logging in via PS2 console on the private servers is possible. I've done it and so have several others. But there is a catch: the console players need to install the OutbreakServer image on a PC connected locally to their router and run just the DNS server part.

So the process is this:

PC setup

1. Import OutbreakServerGUI.ova into VirtualBox
https://drive.google.com/drive/folders/ ... yKYt-T3K94

2. Note down that Local Server's IP. You can find this quickly by hovering the cursor over the blue up/down arrows icon at the top right of the Server window. It will look something like 192.168.0.122

3. Execute in Terminal local-dns-config.sh and change the IPs in there to the Public IPv4 of the server you want to login to, then press Shift+X to exit and Y to save changes

4. Execute in Terminal the restart-dns-server.sh

PS2 Console setup

5. Run Outbreak File 1 or File 2 and go to NETWORK PLAY and select the NET CONNECTION (top) option.

6. Create a new NET CONNECTION setting and put that Local Server IP (from YOUR local server) that you got in step 2. above as the PRIMARY DNS. (You only need to do this once! If you do it for File 1 then just go to NET CONNECTION option again for File 1 or 2 and select that server's setting to login. For any future games just use PREV CONNECTION. But if you want to change to another server then go to NET CONNECTION option again and select the correct server setting for that server.)

Then you should be able to connect same as logging in to obsrv, except you will need to create a new account User ID and Password (use only a-z A-Z 0-9 as other characters are not supported). You will only need to do this once for each game using the right boxes. In future just login with you user ID and password in the left boxes.

hobbes_182
Full Member
Posts: 249
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius
Contact:

Re: Plans to go open source

Postby hobbes_182 » Tue Jan 05, 2021 2:32 pm

Thanks again hill73n!

Guiding me through the darkness as always.

OK I see, this totally makes sense. I'll try this tonight and report back 8)

------------------EDIT ---------------------

It worked baby!

It was weird though, I had a direct connection to my ISP router and I couldn't even connect to obsrv.

I connected to my netgear switch which goes to my ISP router and I could connect to my server and obsrv on the first try.

Oh well, at least we're online ^_^

norisawa
Newbie
Posts: 3
Joined: Sat Dec 21, 2019 8:20 pm

Re: Plans to go open source

Postby norisawa » Wed Apr 07, 2021 12:37 pm

Hello to all,
I created a private server, ob file 1 works correctly instead ob file 2 gives me time out error

User avatar
hill73n
Full Member
Posts: 223
Joined: Mon May 20, 2019 4:49 am
Location: Australia

Re: Plans to go open source

Postby hill73n » Fri Apr 09, 2021 8:50 am

Hello to all,
I created a private server, ob file 1 works correctly instead ob file 2 gives me time out error
Hi. Well done :)

Make sure the File2 server is running in VirtualBox emulation too. But both File1 and File2 servers are stared by default when you boot the Raspberry Pi OutbreakServerGUI image.

Does it do it every time you try to connect on File2?

norisawa
Newbie
Posts: 3
Joined: Sat Dec 21, 2019 8:20 pm

Re: Plans to go open source

Postby norisawa » Sat Apr 10, 2021 8:34 pm

Hello to all,
I created a private server, ob file 1 works correctly instead ob file 2 gives me time out error
Hi. Well done :)

Make sure the File2 server is running in VirtualBox emulation too. But both File1 and File2 servers are stared by default when you boot the Raspberry Pi OutbreakServerGUI image.

Does it do it every time you try to connect on File2?
Thanks for the reply, unfortunately I have tried several times and the server is also started of the file 2...

refan988
Full Member
Posts: 149
Joined: Wed Jul 10, 2013 6:45 pm

Re: Plans to go open source

Postby refan988 » Sat Apr 10, 2021 10:12 pm

Hello to all,
I created a private server, ob file 1 works correctly instead ob file 2 gives me time out error
Hi. Well done :)

Make sure the File2 server is running in VirtualBox emulation too. But both File1 and File2 servers are stared by default when you boot the Raspberry Pi OutbreakServerGUI image.

Does it do it every time you try to connect on File2?
Thanks for the reply, unfortunately I have tried several times and the server is also started of the file 2...
Did you change the server's IP address in the config file to match Virtualbox's network IP address? The IP address for the server should be the same as the one for file 1 server. Double-click on file2config.sh and make sure gs_ip is the same as the file1config.sh config file. Also if you are using your public IP address as the IP address, for file 2 you need to forward tcp ports 8200 and 8590 in addition to tcp port 443.

User avatar
killme
Jr. Member
Posts: 98
Joined: Thu Mar 22, 2018 7:54 pm

Re: Plans to go open source

Postby killme » Thu Apr 22, 2021 3:34 am

I aslo failed on connection, no port forward in my router, and our country blocked port 443 and some else. how to do? :'(
Image

refan988
Full Member
Posts: 149
Joined: Wed Jul 10, 2013 6:45 pm

Re: Plans to go open source

Postby refan988 » Fri Apr 23, 2021 12:44 am

I aslo failed on connection, no port forward in my router, and our country blocked port 443 and some else. how to do? :'(
The only thing you could do is run a vpn with other people that want to connect. I've tried it with both Hamachi and SoftEther and seemed to work fine.

User avatar
killme
Jr. Member
Posts: 98
Joined: Thu Mar 22, 2018 7:54 pm

Re: Plans to go open source

Postby killme » Fri Apr 23, 2021 4:45 am

I aslo failed on connection, no port forward in my router, and our country blocked port 443 and some else. how to do? :'(
The only thing you could do is run a vpn with other people that want to connect. I've tried it with both Hamachi and SoftEther and seemed to work fine.
any video for this? not sure what step did wrong.
Image


Return to “News”



Who is online

Users browsing this forum: Bing [Bot] and 4 guests