Page 7 of 8

Re: Plans to go open source

Posted: Wed Jun 03, 2020 11:11 pm
by Isles487
Hey Isles487, thanks for the info I really appreciate it 8)

I was able to install php7.3-fpm. My new issue is after restarting Apache and checking the DNAS Server instead of getting the "41" in the check, I get: failed: Name or service not known. unable to resolve host address 'gate1.jp.dnas.playstation.org'

I'm sure I did something wrong on my end.

I do have a Pi4 coming in this week, I'll restart there and install php7.3-fpm there too.

Damn, so excited to get this working. Hopefully I can post some good news this week one my Pi comes in :ugeek:
Unable to resolve is a DNS error - did you make sure to point the DNS setting in your outbreak network settings to your server ip address?

Re: Plans to go open source

Posted: Thu Jun 04, 2020 8:51 pm
by r5gamer
Hello i have download on virtual box (Debien 32bits) but i have this error on server file 1 :

Thu Jun 04 14:34:20 MDT 2020 Lobbyserver constructor exception caught!
Thu Jun 04 14:34:20 MDT 2020 Gameserver IP: /192.168.56.1
Thu Jun 04 14:34:21 MDT 2020 Gameserver constructor exception caught!
Jun 04, 2020 2:34:21 PM bioserver.Patch <init>
SEVERE: null
java.io.FileNotFoundException: patch.raw (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at bioserver.Patch.<init>(Patch.java:43)
at bioserver.PacketHandler.run(PacketHandler.java:100)
at java.lang.Thread.run(Thread.java:748)
Thu Jun 04 14:34:21 MDT 2020 Patch loaded: 0 bytes
Thu Jun 04 14:34:22 MDT 2020 server started

Thank you !

Re: Plans to go open source

Posted: Fri Jun 05, 2020 3:41 am
by hobbes_182
Hey Isles487, thanks for the info I really appreciate it 8)

I was able to install php7.3-fpm. My new issue is after restarting Apache and checking the DNAS Server instead of getting the "41" in the check, I get: failed: Name or service not known. unable to resolve host address 'gate1.jp.dnas.playstation.org'

I'm sure I did something wrong on my end.

I do have a Pi4 coming in this week, I'll restart there and install php7.3-fpm there too.

Damn, so excited to get this working. Hopefully I can post some good news this week one my Pi comes in :ugeek:
Unable to resolve is a DNS error - did you make sure to point the DNS setting in your outbreak network settings to your server ip address?
Yeah I changed the IP to my server IP. Not sure if there is anything I missed.

My raspberry Pi finally came in (setting it up now), hopefully, we have smooth sailing and I can get this up and running :ugeek:

>> EDIT 06.05.2020 <<

So I managed to reach the SETTING UP DNS section and ran into another issue :'( (I am working on my Pi4 via SSH)

When I run

Code: Select all

nano /etc/dnsmasq.conf
I get a FILE IS UNWRITABLE error:

Image

Is there a way to make the file writable? I did some Googling and from what I understand I tried:

Code: Select all

sudo chmod +w /etc/dnsmasq.conf
but no luck.

>> EDIT #2 06.05.2020 <<

Nevermind, I ran:

Code: Select all

sudo nano /etc/dnsmasq.conf
and was able to make my edits :geek:

Re: Plans to go open source

Posted: Fri Jun 05, 2020 8:06 pm
by r5gamer
Anyone can help me ?

Re: Plans to go open source

Posted: Sat Jun 06, 2020 4:17 am
by hobbes_182
So I made more progress on my Pi4 last night.

However, I am stuck on the DNAS server check:

Code: Select all

wget --no-check-certificate -O - https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect
(Everything up until this step had been working fine)

It all happened when I restarted Apache (which was previously running fine). After I restarted I got this error:

Image

I checked "systemctl status apache.service" and got: (feel free to open image in new tab)

Image

So the log is telling me that there is a "syntax error on line 527, perhaps misspelled or defined by a module not included in the server configuration"

I then checked line 527 which is where "RewriteEngine" starts: (feel free to open image in new tab)

Image

One thing that also caught my eye was the line that reads: "SetHandler "proxy:Unix:/var/run/php/php7.0-fpm.sock|fcgi://127.0.0.1"

What I did for my setup was install php7.3-fpm since I could not install php7.0-fpm

Could this also be an issue? I have followed the pdf, and I have changed the IP to match my server IP. I'm sure it's probably something I missed [again :o ]

Re: Plans to go open source

Posted: Sun Jul 12, 2020 9:30 pm
by refan988
I uploaded a different VirtualBox image that automatically starts both servers on startup. All you got to do is change the IP settings for both servers and possibly the dns if you are trying to play on the server locally. New Server link.

Re: Plans to go open source

Posted: Mon Jul 13, 2020 5:28 pm
by Tegato
I uploaded a different VirtualBox image that automatically starts both servers on startup. All you got to do is change the IP settings for both servers and possibly the dns if you are trying to play on the server locally. New Server link.
Thank you! I'll give it a go at some point. :)

Re: Plans to go open source

Posted: Mon Jul 13, 2020 5:40 pm
by hobbes_182
I uploaded a different VirtualBox image that automatically starts both servers on startup. All you got to do is change the IP settings for both servers and possibly the dns if you are trying to play on the server locally. New Server link.
Awesome thanks so much! Gonna try running a Virtual Machine on a Pi4 (4gb ram)

Re: Plans to go open source

Posted: Wed Jul 15, 2020 3:10 am
by Ji29
@refan988
Hey!
so I tried your new image in Vbox and am in an endless loop with loading initial ramdisk >25minutes so far and no boot. I wonder if its an initrd thats too large? Also I removed quiet from the launch line and its still doesnt seem to boot

Re: Plans to go open source

Posted: Wed Jul 15, 2020 3:42 am
by refan988
I'm not sure why it wouldn't run, but I created the appliance file on Version 6.1.8 r137981 (Qt5.6.2). I will download it and try it out to see if it's been corrupted somehow.

Re: Plans to go open source

Posted: Wed Jul 15, 2020 4:04 am
by Ji29
@refan988

Apologies, It seemed to be my copy with Virtual box 6.0. After a quick update it boots no problem!
I'm not sure what would cause that issue in 6.0 as your previous image worked perfectly!

Many thanks!

Re: Plans to go open source

Posted: Wed Jul 15, 2020 4:11 am
by refan988
Glad it works for you now! Let me know if you need any help setting the server up.

Re: Plans to go open source

Posted: Sat Jul 25, 2020 3:16 am
by Falkiner
Hey everyone!

I was trying to create a server in Debian 10, but as @hobbes_182 when I try to wget the from https://gate1.jp.dnas.playstation.org/g ... _i-connect doesn't work...

But Nslookup is working

Image

Does anyone have a clue?

Thanks!

--------- EDIT 07/25/2020 ---------

I've just needed to edit /etc/resolv.conf and point the nameserver to 127.0.0.1 (I need to make my machine use itself as a dns server https://support.rackspace.com/how-to/ch ... -on-linux/)

Now I'm having SSL Errors
Image

Any help would be greatly appreciated :)

Re: Plans to go open source

Posted: Sat Jul 25, 2020 2:51 pm
by refan988
I had the same issue. The dnas only seems to work in debian 9, not 10.

Re: Plans to go open source

Posted: Sat Jul 25, 2020 6:00 pm
by Falkiner
I had the same issue. The dnas only seems to work in debian 9, not 10.
Hey Refan! Thanks for the reply, I will try creating the server on a Debian 9! :)

--------- EDIT 07/25/2020 ---------

I've managed to get the server working in a Debian 9 machine hosted on Google Cloud! :)

Image

I would like to thank some people:

the_fog (creating the project and making it open source)
refan988 (for trying to create, sharing your problems, your OVA file and telling me to use debian9)
Isles487 (for the java compilation commands and debugging about mysql_query problem)

Also, I've corrected the files for File#1 to use mysqli function instead mysql function so you anyone will be able to use it with PHP7: Download it Here