Plans to go open source

short notes for those not reading all the forums
User avatar
Isles487
Sr. Member
Posts: 1124
Joined: Sat Jul 27, 2013 6:10 pm

Re: Plans to go open source

Postby Isles487 » Wed Jun 03, 2020 11:11 pm

Hey Isles487, thanks for the info I really appreciate it 8)

I was able to install php7.3-fpm. My new issue is after restarting Apache and checking the DNAS Server instead of getting the "41" in the check, I get: failed: Name or service not known. unable to resolve host address 'gate1.jp.dnas.playstation.org'

I'm sure I did something wrong on my end.

I do have a Pi4 coming in this week, I'll restart there and install php7.3-fpm there too.

Damn, so excited to get this working. Hopefully I can post some good news this week one my Pi comes in :ugeek:
Unable to resolve is a DNS error - did you make sure to point the DNS setting in your outbreak network settings to your server ip address?
Image

r5gamer
Newbie
Posts: 2
Joined: Thu Jun 04, 2020 8:47 pm

Re: Plans to go open source

Postby r5gamer » Thu Jun 04, 2020 8:51 pm

Hello i have download on virtual box (Debien 32bits) but i have this error on server file 1 :

Thu Jun 04 14:34:20 MDT 2020 Lobbyserver constructor exception caught!
Thu Jun 04 14:34:20 MDT 2020 Gameserver IP: /192.168.56.1
Thu Jun 04 14:34:21 MDT 2020 Gameserver constructor exception caught!
Jun 04, 2020 2:34:21 PM bioserver.Patch <init>
SEVERE: null
java.io.FileNotFoundException: patch.raw (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at bioserver.Patch.<init>(Patch.java:43)
at bioserver.PacketHandler.run(PacketHandler.java:100)
at java.lang.Thread.run(Thread.java:748)
Thu Jun 04 14:34:21 MDT 2020 Patch loaded: 0 bytes
Thu Jun 04 14:34:22 MDT 2020 server started

Thank you !

User avatar
hobbes_182
Full Member
Posts: 237
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius

Re: Plans to go open source

Postby hobbes_182 » Fri Jun 05, 2020 3:41 am

Hey Isles487, thanks for the info I really appreciate it 8)

I was able to install php7.3-fpm. My new issue is after restarting Apache and checking the DNAS Server instead of getting the "41" in the check, I get: failed: Name or service not known. unable to resolve host address 'gate1.jp.dnas.playstation.org'

I'm sure I did something wrong on my end.

I do have a Pi4 coming in this week, I'll restart there and install php7.3-fpm there too.

Damn, so excited to get this working. Hopefully I can post some good news this week one my Pi comes in :ugeek:
Unable to resolve is a DNS error - did you make sure to point the DNS setting in your outbreak network settings to your server ip address?
Yeah I changed the IP to my server IP. Not sure if there is anything I missed.

My raspberry Pi finally came in (setting it up now), hopefully, we have smooth sailing and I can get this up and running :ugeek:

>> EDIT 06.05.2020 <<

So I managed to reach the SETTING UP DNS section and ran into another issue :'( (I am working on my Pi4 via SSH)

When I run

Code: Select all

nano /etc/dnsmasq.conf
I get a FILE IS UNWRITABLE error:

Image

Is there a way to make the file writable? I did some Googling and from what I understand I tried:

Code: Select all

sudo chmod +w /etc/dnsmasq.conf
but no luck.

>> EDIT #2 06.05.2020 <<

Nevermind, I ran:

Code: Select all

sudo nano /etc/dnsmasq.conf
and was able to make my edits :geek:
Image
Image

r5gamer
Newbie
Posts: 2
Joined: Thu Jun 04, 2020 8:47 pm

Re: Plans to go open source

Postby r5gamer » Fri Jun 05, 2020 8:06 pm

Anyone can help me ?

User avatar
hobbes_182
Full Member
Posts: 237
Joined: Thu Jan 23, 2014 12:08 am
Location: _mobius

Re: Plans to go open source

Postby hobbes_182 » Sat Jun 06, 2020 4:17 am

So I made more progress on my Pi4 last night.

However, I am stuck on the DNAS server check:

Code: Select all

wget --no-check-certificate -O - https://gate1.jp.dnas.playstation.org/gai-gw/v2.5_i-connect
(Everything up until this step had been working fine)

It all happened when I restarted Apache (which was previously running fine). After I restarted I got this error:

Image

I checked "systemctl status apache.service" and got: (feel free to open image in new tab)

Image

So the log is telling me that there is a "syntax error on line 527, perhaps misspelled or defined by a module not included in the server configuration"

I then checked line 527 which is where "RewriteEngine" starts: (feel free to open image in new tab)

Image

One thing that also caught my eye was the line that reads: "SetHandler "proxy:Unix:/var/run/php/php7.0-fpm.sock|fcgi://127.0.0.1"

What I did for my setup was install php7.3-fpm since I could not install php7.0-fpm

Could this also be an issue? I have followed the pdf, and I have changed the IP to match my server IP. I'm sure it's probably something I missed [again :o ]
Image
Image


Return to “News”



Who is online

Users browsing this forum: No registered users and 9 guests

cron